summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2009-05-17 18:48:20 +0000
committerBob Ippolito <bob@redivi.com>2009-05-17 18:48:20 +0000
commit0c067d195decc908ce2c3076f3c92f8fa3f19d03 (patch)
tree3a5c541a5f27d01c226b84a75281c58c7c375fb9 /setup.py
parent7f6c62499a21139ff486f44787f6850ac6ce6f02 (diff)
downloadsimplejson-0c067d195decc908ce2c3076f3c92f8fa3f19d03.tar.gz
require setuptools 0.6c9, remove old cygwin hack
git-svn-id: http://simplejson.googlecode.com/svn/trunk@187 a4795897-2c25-0410-b006-0d3caba88fa1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 1 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 78a453d..44eb1a2 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,7 @@
#!/usr/bin/env python
from ez_setup import use_setuptools
-import sys
-if 'cygwin' in sys.platform.lower():
- min_version='0.6c6'
-else:
- min_version='0.6a9'
-try:
- use_setuptools(min_version=min_version)
-except TypeError:
- # If a non-local ez_setup is already imported, it won't be able to
- # use the min_version kwarg and will bail with TypeError
- use_setuptools()
+use_setuptools()
from setuptools import setup, find_packages, Extension, Feature
from distutils.command.build_ext import build_ext