diff options
author | Bob Ippolito <bob@redivi.com> | 2012-12-26 12:48:47 -0800 |
---|---|---|
committer | Bob Ippolito <bob@redivi.com> | 2012-12-28 11:03:45 -0800 |
commit | 5846148410234f6466aefcddc68683811577998e (patch) | |
tree | 27af6427a02a0c995ea382c029027674e1031a2f /setup.py | |
parent | 57d980277f8d1d6324904edd43e1a730572b64b6 (diff) | |
download | simplejson-5846148410234f6466aefcddc68683811577998e.tar.gz |
First pass at Python 3.3 compatibility
First pass at Python 3.3 compatibility, bump to 3.0.0
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 27 |
1 files changed, 14 insertions, 13 deletions
@@ -7,7 +7,7 @@ from distutils.errors import CCompilerError, DistutilsExecError, \ DistutilsPlatformError IS_PYPY = hasattr(sys, 'pypy_translation_info') -VERSION = '2.6.2' +VERSION = '3.0.0' DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python" LONG_DESCRIPTION = open('README.rst', 'r').read() @@ -36,13 +36,13 @@ class ve_build_ext(build_ext): def run(self): try: build_ext.run(self) - except DistutilsPlatformError, x: + except DistutilsPlatformError: raise BuildFailed() def build_extension(self, ext): try: build_ext.build_extension(self, ext) - except ext_errors, x: + except ext_errors: raise BuildFailed() @@ -89,16 +89,17 @@ def run_setup(with_binary): try: run_setup(not IS_PYPY) except BuildFailed: - BUILD_EXT_WARNING = "WARNING: The C extension could not be compiled, speedups are not enabled." - print '*' * 75 - print BUILD_EXT_WARNING - print "Failure information, if any, is above." - print "I'm retrying the build without the C extension now." - print '*' * 75 + BUILD_EXT_WARNING = ("WARNING: The C extension could not be compiled, " + "speedups are not enabled.") + print('*' * 75) + print(BUILD_EXT_WARNING) + print("Failure information, if any, is above.") + print("I'm retrying the build without the C extension now.") + print('*' * 75) run_setup(False) - print '*' * 75 - print BUILD_EXT_WARNING - print "Plain-Python installation succeeded." - print '*' * 75 + print('*' * 75) + print(BUILD_EXT_WARNING) + print("Plain-Python installation succeeded.") + print('*' * 75) |