summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am33
1 files changed, 29 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 73c1b33..4e94d02 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,8 +1,33 @@
-## Process this file with automake to produce Makefile.in
+# Copyright 1997-1998, 2005-2014 Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
-include gnulib.mk
+AM_CFLAGS =
+AM_CPPFLAGS =
+BUILT_SOURCES =
+CLEANFILES =
+EXTRA_DIST =
+MAINTAINERCLEANFILES =
+MOSTLYCLEANDIRS =
+MOSTLYCLEANFILES =
+SUFFIXES =
+noinst_LIBRARIES =
-SUFFIXES += .a .o .c .y .l .h .sh .elc .el
+include gnulib.mk
-AM_CPPFLAGS += -I$(top_srcdir)/lib -I$(top_srcdir) -I$(top_builddir)/lib
+AM_CFLAGS += $(GNULIB_WARN_CFLAGS) $(WERROR_CFLAGS)
+libsed_a_LIBADD += $(LIBOBJS) $(ALLOCA)
+libsed_a_DEPENDENCIES += $(LIBOBJS) $(ALLOCA)