summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2004-11-09 19:04:52 +0000
committerPaolo Bonzini <bonzini@gnu.org>2008-01-09 16:10:50 +0100
commitc27b981abae6fc98dea36bcf4cb219b8a81928df (patch)
tree114f761da3b7535bac0a8cc8c1a6f5b5ccf2da84 /configure.ac
parent6a02cd80dca54363b0559920804012ba63ca3216 (diff)
downloadsed-c27b981abae6fc98dea36bcf4cb219b8a81928df.tar.gz
add tagging conventions and fix configure for gettext 0.14
git-archimport-id: bonzini@gnu.org--2004b/sed--stable--4.1--patch-15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2a866b8..ce22b85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,9 +132,15 @@ AM_CONDITIONAL(MAKEINFO_HTML, test "x$enable_html" = xmakeinfo)
AM_CONDITIONAL(TEXI2HTML_HTML, test "x$enable_html" = xtexi2html)
-ALL_LINGUAS="af ca cs da de el eo es et fi fr ga gl he hr hu id it ja ko nl pl pt_BR ro ru sk sl sr sv tr zh_CN"
-AM_GNU_GETTEXT_VERSION(0.11)
-AM_GNU_GETTEXT(, need-ngettext)
+AC_DEFUN([AM_MKINSTALLDIRS], [MKINSTALLDIRS="$mkdir_p" AC_SUBST(MKINSTALLDIRS)])
+AM_GNU_GETTEXT_VERSION(0.14)
+AM_GNU_GETTEXT(no-libtool, need-ngettext, ../intl)
+AC_CONFIG_COMMANDS([gettext-fix], [
+ sed -e 's/^mkinstalldirs *=.*/mkinstalldirs=$(MKINSTALLDIRS)/' \
+ -e 's/$(DOMAIN)/'$PACKAGE'/g' \
+ -e 's/$(XGETTEXT_OPTIONS)/-k_ -kN_/g' \
+ -e 's/$(top_builddir)/../g' po/Makefile > po/Makefile.tmp
+ mv po/Makefile.tmp po/Makefile], [PACKAGE=$PACKAGE])
AC_CONFIG_FILES([bootstrap.sh], chmod +x bootstrap.sh)
AC_CONFIG_FILES([Makefile doc/Makefile \