summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2006-12-15 12:30:25 +0000
committerPaolo Bonzini <bonzini@gnu.org>2008-01-09 16:12:20 +0100
commitba68fb42b8db505a89da4987df5936997a3c226a (patch)
tree28c41aecc082a91b95312909851db53cb1bda464 /configure.ac
parent2128ec657b3d6bb3378424d0ddda923cdf8e2713 (diff)
downloadsed-ba68fb42b8db505a89da4987df5936997a3c226a.tar.gz
--posix disables all extensions to regular expressions
2006-12-15 Paolo Bonzini <bonzini@gnu.org> * sed/regexp.c: Disable all extensions on --posix. git-archimport-id: bonzini@gnu.org--2004b/sed--stable--4.1--patch-84
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53f2335..2fa56a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,13 @@ enable_html=no)
AM_CONDITIONAL(BUILD_HTML, test "x$enable_html" != xno)
+# Check whether we are able to follow symlinks
+AC_CHECK_FUNC(lstat, have_lstat=yes)
+AC_CHECK_FUNC(readlink, have_readlink=yes)
+if test "x$have_lstat" = xyes -a "x$have_readlink" = xyes; then
+ AC_DEFINE(ENABLE_FOLLOW_SYMLINKS, ,[Follow symlinks when processing in place])
+fi
+
: ${TEXI2HTML=texi2html -monolithic}
AC_SUBST(TEXI2HTML)