summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-10-03 10:01:59 +0200
committerPaolo Bonzini <bonzini@gnu.org>2008-10-03 10:34:54 +0200
commit51d634a52ff43e7197d96a2284377a4ceb1aa4fc (patch)
treeffa2c22b3a8d1d3035ad640b13f6232d8e2e07d7 /configure.ac
parent74687e4bf7b3df0953a9226cf7ac9124cdc7f0db (diff)
downloadsed-51d634a52ff43e7197d96a2284377a4ceb1aa4fc.tar.gz
switch to external gettext
2008-10-03 Paolo Bonzini <bonzini@gnu.org> Jim Meyering <meyering@redhat.com> * Makefile.am: Remove intl subdir. Require Automake 1.10. * configure.ac: Remove useless macros, switch to external gettext. * lib/Makefile.am: Remove intl subdir from CPPFLAGS. * sed/Makefile.am: Remove intl subdir from CPPFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index d7a6a1a..6c59cf4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,14 +12,10 @@ AC_DEFINE_UNQUOTED(SED_FEATURE_VERSION, "$SED_FEATURE_VERSION",
AC_SUBST(SED_FEATURE_VERSION)
AC_PROG_CC
-gl_DISABLE_THREADS
-AC_USE_SYSTEM_EXTENSIONS
-AC_GNU_SOURCE
gl_EARLY
-AC_SYS_LARGEFILE
-AC_SYS_LONG_FILE_NAMES
-
gl_INIT
+gl_DISABLE_THREADS
+AC_SYS_LONG_FILE_NAMES
AC_CACHE_CHECK([whether -lcP is needed], [sed_cv_libcp_needed], [
AC_TRY_RUN([
#include <stdio.h>
@@ -55,7 +51,7 @@ AC_FUNC_VPRINTF
AC_DEFUN([AM_MKINSTALLDIRS], [MKINSTALLDIRS="$mkdir_p" AC_SUBST(MKINSTALLDIRS)])
AM_GNU_GETTEXT_VERSION(0.15)
-AM_GNU_GETTEXT(no-libtool, need-ngettext, ../intl)
+AM_GNU_GETTEXT([external])
AC_CHECK_FUNCS_ONCE(isatty bcopy bzero isascii memcpy memset strchr strtoul
popen pathconf isblank fchown fchmod setlocale wcrtomb
@@ -92,5 +88,5 @@ AC_CONFIG_FILES([bootstrap.sh], chmod +x bootstrap.sh)
AC_CONFIG_FILES([testsuite/version.good:testsuite/version.gin])
AC_CONFIG_FILES([Makefile doc/Makefile \
lib/Makefile sed/Makefile testsuite/Makefile \
-po/Makefile.in intl/Makefile])
+po/Makefile.in])
AC_OUTPUT