summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2007-09-26 07:39:49 +0000
committerPaolo Bonzini <bonzini@gnu.org>2008-01-09 16:12:29 +0100
commit34b083cdc5bc29fe2e0feae6e5d31101662d437a (patch)
tree5ca1b6d5fce402d1aff633c5a9013c37eaa75e3d /configure.ac
parent95792f701c5797ae07f5784f1b5cc989355be7ff (diff)
downloadsed-34b083cdc5bc29fe2e0feae6e5d31101662d437a.tar.gz
document q/Q in sed man page, improve html doc generation
2007-10-25 Paolo Bonzini <bonzini@gnu.org> Mike Frysinger <vapier@gentoo.org> * doc/sed.x (q, Q): Document argument. * configure.ac: Remove texi2html checks. * doc/Makefile.am: Remove rules for sed.html, always distribute it. git-archimport-id: bonzini@gnu.org--2004b/sed--stable--4.1--patch-97
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 0 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index fb4ae70..e2c5f6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,12 +79,6 @@ if test "x$enable_regex_tests" = xyes; then
[Include BSD functions in regex, used by the testsuite])
fi
-AC_ARG_ENABLE(html,
-[ --enable-html build HTML manual (default=no)], ,
-enable_html=no)
-
-AM_CONDITIONAL(BUILD_HTML, test "x$enable_html" != xno)
-
# Check whether we are able to follow symlinks
AC_CHECK_FUNC(lstat, have_lstat=yes)
AC_CHECK_FUNC(readlink, have_readlink=yes)
@@ -92,30 +86,6 @@ if test "x$have_lstat" = xyes -a "x$have_readlink" = xyes; then
AC_DEFINE(ENABLE_FOLLOW_SYMLINKS, ,[Follow symlinks when processing in place])
fi
-: ${TEXI2HTML=texi2html -monolithic}
-AC_SUBST(TEXI2HTML)
-
-AC_MSG_CHECKING(how to build HTML documentation)
-if eval $am_missing_run makeinfo --help 2>&1 | grep .-html > /dev/null; then
- AC_MSG_RESULT(with makeinfo)
- enable_html=makeinfo
-else
- if $TEXI2HTML --help 2>&1 | grep monolithic > /dev/null; then
- AC_MSG_RESULT(with texi2html)
- enable_html=texi2html
- else
- AC_MSG_RESULT(not built)
- if test "x$enable_html" != xno; then
- AC_MSG_ERROR(cannot build HTML documentation, install makeinfo 4.0 or texi2html)
- fi
- enable_html=no
- fi
-fi
-
-AM_CONDITIONAL(MAKEINFO_HTML, test "x$enable_html" = xmakeinfo)
-AM_CONDITIONAL(TEXI2HTML_HTML, test "x$enable_html" = xtexi2html)
-
-
AC_CONFIG_FILES([bootstrap.sh], chmod +x bootstrap.sh)
AC_CONFIG_FILES([testsuite/version.good:testsuite/version.gin])
AC_CONFIG_FILES([Makefile doc/Makefile \