summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2004-10-20 21:42:31 +0000
committerPaolo Bonzini <bonzini@gnu.org>2004-10-20 21:42:31 +0000
commit9c9919efe2166efd32409054005619062624226c (patch)
tree29cf0853d8049b5d73337285c437fd35eb96086e /Makefile.am
downloadsed-9c9919efe2166efd32409054005619062624226c.tar.gz
initial import
(automatically generated log message) git-archimport-id: bonzini@gnu.org--2004b/sed--stable--4.1--base-0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..f0aaa7f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,30 @@
+## Process this file with automake to produce Makefile.in
+
+# Automake requirements
+AUTOMAKE_OPTIONS = gnits 1.8
+ACLOCAL_AMFLAGS = -I config
+
+PACKAGE = sed
+
+SUBDIRS = intl lib po sed doc testsuite
+
+noinst_DATA = bootstrap.sh
+noinst_HEADERS = basicdefs.h
+
+EXTRA_DIST = BUGS THANKS COPYING.DOC README.boot bootstrap.sh \
+ config/texi2dvi config/help2man
+
+html:
+ cd doc && make html
+
+update-regex:
+ cd lib && \
+ HOST=sources.redhat.com && \
+ BASEURL="http://$$HOST/cgi-bin/cvsweb.cgi/~checkout~/libc/posix" && \
+ QUERY='cvsroot=glibc&content-type=text/plain' && \
+ wget -O regcomp.c "$$BASEURL/regcomp.c?$$QUERY" && \
+ wget -O regexec.c "$$BASEURL/regexec.c?$$QUERY" && \
+ wget -O regex.c "$$BASEURL/regex.c?$$QUERY" && \
+ wget -O regex_.h "$$BASEURL/regex.h?$$QUERY" && \
+ wget -O regex_internal.c "$$BASEURL/regex_internal.c?$$QUERY" && \
+ wget -O regex_internal.h "$$BASEURL/regex_internal.h?$$QUERY"