summaryrefslogtreecommitdiff
path: root/src/setup.py
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2002-02-26 21:00:23 +0000
committerSteven Knight <knight@baldmt.com>2002-02-26 21:00:23 +0000
commit024596366a4d3c03942015b2c7e09ed080d8a6b2 (patch)
tree746050e42e425bcc4a10ee751bc775b9d04f070e /src/setup.py
parent22377ca1715d2b67a5e72cdede0fb0103e4c7ff1 (diff)
downloadscons-git-024596366a4d3c03942015b2c7e09ed080d8a6b2.tar.gz
Extend SConstruct et al. to build .zip files, and to build the scons-src package on Win32 platforms.
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/setup.py b/src/setup.py
index d664527f8..73abe1997 100644
--- a/src/setup.py
+++ b/src/setup.py
@@ -40,6 +40,7 @@ class my_install_lib(install_lib):
def finalize_options(self):
install_lib.finalize_options(self)
head = self.install_dir
+ drive, head = os.path.splitdrive(self.install_dir)
while head:
if head == os.sep:
head = None
@@ -47,17 +48,17 @@ class my_install_lib(install_lib):
else:
head, tail = os.path.split(head)
if tail[:6] == "python":
- self.install_dir = os.path.join(head, "scons")
+ self.install_dir = os.path.join(drive + head, "scons")
# Our original packaging scheme placed the build engine
# in a private library directory that contained the SCons
# version number in the directory name. Here's how this
# was supported here. See the Construct file for details
# on other files that would need to be changed to support
# this as well.
- #self.install_dir = os.path.join(head, "scons-__VERSION__")
+ #self.install_dir = os.path.join(drive + head, "scons-__VERSION__")
return
elif tail[:6] == "Python":
- self.install_dir = os.path.join(head, tail)
+ self.install_dir = os.path.join(drive + head, tail)
return
arguments = {