summaryrefslogtreecommitdiff
path: root/source/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/configure.in b/source/configure.in
index 3a6269145d7..0367b5f8d07 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -4195,7 +4195,7 @@ if test x"$HAVE_WINBIND" = x"yes"; then
EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/wbinfo\$(EXEEXT)"
EXTRA_SBIN_PROGS="$EXTRA_SBIN_PROGS bin/winbindd\$(EXEEXT)"
- if test x"$BLDSHARED" = x"true"; then
+ if test $BLDSHARED = true; then
SHLIB_PROGS="$SHLIB_PROGS $WINBIND_NSS $WINBIND_WINS_NSS"
if test x"$with_pam" = x"yes"; then
@@ -4287,10 +4287,10 @@ done
for i in `echo $default_shared_modules | sed -e's/,/ /g'`
do
- dnl Fall back to static if dlopen() is not available
+ dnl Fall back to static if we cannot build shared libraries
eval MODULE_DEFAULT_$i=STATIC
- if test x"$ac_cv_func_dlopen" = xyes; then
+ if test $BLDSHARED = true; then
eval MODULE_DEFAULT_$i=SHARED
fi
done