summaryrefslogtreecommitdiff
path: root/docs-xml/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'docs-xml/configure.ac')
-rw-r--r--docs-xml/configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/docs-xml/configure.ac b/docs-xml/configure.ac
index fe889a2f33a..8c26692630b 100644
--- a/docs-xml/configure.ac
+++ b/docs-xml/configure.ac
@@ -55,4 +55,12 @@ fi
AC_SUBST(TARGETS)
-AC_OUTPUT( Makefile.settings build/catalog.xml)
+if test x"$DOC_VERSION" = x; then
+ AC_MSG_ERROR([Please export DOC_VERSION variable])
+else
+ AC_MSG_RESULT([DOC_VERSION: ${DOC_VERSION}])
+fi
+
+doc_version="${DOC_VERSION}"
+AC_SUBST(doc_version)
+AC_OUTPUT( Makefile.settings build/catalog.xml build/DTD/samba.build.version)