summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBrad Smith <brad@comstyle.com>2012-02-28 20:45:41 +0100
committerKarolin Seeger <kseeger@samba.org>2012-02-28 20:45:41 +0100
commita0d51949abde68134eb35150d797387a1fb57ab7 (patch)
treed7b1e90f0da3165ae68d46681d6615969f79722d /source3/configure.in
parent990274481795a47376cdbc95d5f80d830079d702 (diff)
downloadsamba-a0d51949abde68134eb35150d797387a1fb57ab7.tar.gz
s3: Add sys_statvfs() wrapper support for OpenBSD/FreeBSD/DragonFly.
Fix bug #8777.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index d8d3a1fd850..67e08c1cb92 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6754,13 +6754,21 @@ CFLAGS=$CFLAGS_SAVE
# Start
AC_CHECK_FUNC(getmntent)
-AC_CHECK_HEADERS(sys/statfs.h)
+AC_CHECK_HEADERS(sys/param.h sys/statfs.h sys/mount.h)
AC_MSG_CHECKING([vfs_fileid: checking for statfs() and struct statfs.f_fsid)])
AC_CACHE_VAL(vfsfileid_cv_statfs,[
AC_TRY_RUN([
#include <sys/types.h>
+ #ifdef HAVE_SYS_PARAM_H
+ #include <sys/param.h>
+ #endif
+ #ifdef HAVE_SYS_MOUNT_H
+ #include <sys/mount.h>
+ #endif
+ #ifdef HAVE_SYS_STATFS_H
#include <sys/statfs.h>
+ #endif
int main(void)
{
struct statfs fsd;