summaryrefslogtreecommitdiff
path: root/source/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-02-21 00:34:16 +0100
committerMichael Adam <obnox@samba.org>2008-02-21 10:27:56 +0100
commitb5e894cb3b4d447bd8e8c3f461508c4cf3f630c1 (patch)
treedefab14ffd71aac04fe10ec14f319e2f706facac /source/configure.in
parent310c121faf5effeca9ab0df3591c486dd4982749 (diff)
downloadsamba-b5e894cb3b4d447bd8e8c3f461508c4cf3f630c1.tar.gz
Remove check for secure mkstemp from configure.in.
It has moved to libreplace. Michael
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in22
1 files changed, 0 insertions, 22 deletions
diff --git a/source/configure.in b/source/configure.in
index 4cc98363d5e..dcd083fa289 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2615,28 +2615,6 @@ if test x"$samba_cv_HAVE_BROKEN_GETGROUPS" = x"yes"; then
AC_DEFINE(HAVE_BROKEN_GETGROUPS,1,[Whether getgroups is broken])
fi
-AC_CACHE_CHECK([for secure mkstemp],samba_cv_HAVE_SECURE_MKSTEMP,[
-AC_TRY_RUN([#include <stdlib.h>
-#include <sys/types.h>
-#include <sys/stat.h>
-#include <unistd.h>
-main() {
- struct stat st;
- char tpl[20]="/tmp/test.XXXXXX";
- int fd = mkstemp(tpl);
- if (fd == -1) exit(1);
- unlink(tpl);
- if (fstat(fd, &st) != 0) exit(1);
- if ((st.st_mode & 0777) != 0600) exit(1);
- exit(0);
-}],
-samba_cv_HAVE_SECURE_MKSTEMP=yes,
-samba_cv_HAVE_SECURE_MKSTEMP=no,
-samba_cv_HAVE_SECURE_MKSTEMP=cross)])
-if test x"$samba_cv_HAVE_SECURE_MKSTEMP" = x"yes"; then
- AC_DEFINE(HAVE_SECURE_MKSTEMP,1,[Whether mkstemp is secure])
-fi
-
AC_CACHE_CHECK([for broken readdir],samba_cv_HAVE_BROKEN_READDIR,[
AC_TRY_RUN([#include "${srcdir-.}/tests/os2_delete.c"],
[samba_cv_HAVE_BROKEN_READDIR=no],