summaryrefslogtreecommitdiff
path: root/source/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-03-08 18:05:55 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:18:29 -0500
commit262e4e1fd8398934780db354fcc5316368032d7b (patch)
tree995dfea206b044345fae2ac02dad6af12fa8c1e4 /source/configure.in
parent1106db7ea148253e3b5f0806b2d5efcd094b202e (diff)
downloadsamba-262e4e1fd8398934780db354fcc5316368032d7b.tar.gz
r21763: Add support for the UNIX_INFO2 infolevel.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 38449dae334..3e407cf5dcf 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2976,6 +2976,23 @@ if test x"$samba_cv_HAVE_STAT_ST_BLKSIZE" = x"yes"; then
AC_DEFINE(HAVE_STAT_ST_BLKSIZE,1,[Whether the stat struct has a st_blksize property])
fi
+AC_CACHE_CHECK([for st_flags in struct stat],
+ samba_cv_HAVE_STAT_ST_FLAGS,
+ [
+ AC_TRY_COMPILE([#include <sys/types.h>
+#include <sys/stat.h>
+#include <unistd.h>],
+ [struct stat st; st.st_flags = 0;],
+ samba_cv_HAVE_STAT_ST_FLAGS=yes,
+ samba_cv_HAVE_STAT_ST_FLAGS=no,
+ samba_cv_HAVE_STAT_ST_FLAGS=cross)
+ ])
+
+if test x"$samba_cv_HAVE_STAT_ST_FLAGS" = x"yes"; then
+ AC_DEFINE(HAVE_STAT_ST_FLAGS, 1,
+ [Whether the stat struct has a st_flags member])
+fi
+
case "$host_os" in
*linux*)
AC_CACHE_CHECK([for broken RedHat 7.2 system header files],samba_cv_BROKEN_REDHAT_7_SYSTEM_HEADERS,[