summaryrefslogtreecommitdiff
path: root/ctdb/configure.ac
diff options
context:
space:
mode:
authorRonnie Sahlberg <sahlberg@ronnie>2007-10-08 14:05:22 +1000
committerRonnie Sahlberg <sahlberg@ronnie>2007-10-08 14:05:22 +1000
commit292e9d91095e74a68349089575641fca835d6a3e (patch)
tree7721efb82c275cecaf63e569f9ddb108d4e61253 /ctdb/configure.ac
parentab5d098bf666dc6093c8a56424f7df60b688f120 (diff)
downloadsamba-292e9d91095e74a68349089575641fca835d6a3e.tar.gz
add an initial test version of an ip multiplex tool that allows us
to have one single public ip address for the entire cluster. this ip address is attached to lo on all nodes but only the recmaster will respond to arp requests for this address. the recmaster then runs an ipmux process that will pass any incoming packets to this ip address onto the other node sin the cluster based on the ip address of the client host to use this feature one must 1, have one fixed ip address in the customers network attached permanently attached to an interface 2, set CTDB_PUBLI_INTERFACE= to specify on which interface the clients attach to the node 3, CTDB_SINGLE_PUBLI_IP=ip-address to specify which ipaddress should be the "single public ip address" to test with only one single client, attach several ip addresses to the client and ping the public address from the client with different -I options. look in network trace to see to which node the packet is passed onto. (This used to be ctdb commit 50d648c95e4e6d7c2867a034c2b550086d853320)
Diffstat (limited to 'ctdb/configure.ac')
-rw-r--r--ctdb/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/ctdb/configure.ac b/ctdb/configure.ac
index 63ebc28c91b..bd2a77d0b6e 100644
--- a/ctdb/configure.ac
+++ b/ctdb/configure.ac
@@ -18,11 +18,13 @@ case `uname` in
Linux*)
CTDB_SYSTEM_OBJ=common/system_linux.o
CTDB_SCSI_IO=bin/scsi_io
+ CTDB_IPMUX=bin/ctdb_ipmux
CTDB_PCAP_LDFLAGS=
;;
AIX*)
CTDB_SYSTEM_OBJ=common/system_aix.o
CTDB_SCSI_IO=
+ CTDB_IPMUX=
CTDB_PCAP_LDFLAGS=-lpcap
;;
*)
@@ -63,6 +65,7 @@ fi
AC_SUBST(EXTRA_OBJ)
AC_SUBST(CTDB_SYSTEM_OBJ)
AC_SUBST(CTDB_SCSI_IO)
+AC_SUBST(CTDB_IPMUX)
AC_SUBST(CTDB_PCAP_LDFLAGS)
AC_OUTPUT(Makefile)