summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Dykstra <dwd@samba.org>1999-02-03 15:11:40 +0000
committerDavid Dykstra <dwd@samba.org>1999-02-03 15:11:40 +0000
commite68f34816f462dea879082b69eb1df7cfb1b0c0f (patch)
tree974d73b3cc32b6f54389a812893118677bbc615e /configure.in
parent716baed7ff23f949861f0eb369c013408e17f984 (diff)
downloadrsync-e68f34816f462dea879082b69eb1df7cfb1b0c0f.tar.gz
Add alternate implementation of waitpid() for systems that have wait4 but
not wait3, in particular Amdahl's SVR2-based UTS 2.1.2. The code comes from apache, but I contributed it to apache in the first place.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 79aab779..25bf768c 100644
--- a/configure.in
+++ b/configure.in
@@ -49,7 +49,7 @@ fi
AC_FUNC_MEMCMP
AC_FUNC_UTIME_NULL
-AC_CHECK_FUNCS(waitpid getcwd strdup strerror chown chmod mknod)
+AC_CHECK_FUNCS(waitpid wait4 getcwd strdup strerror chown chmod mknod)
AC_CHECK_FUNCS(fchmod fstat strchr readlink link utime utimes strftime)
AC_CHECK_FUNCS(memmove getopt_long lchown vsnprintf snprintf setsid glob strpbrk)
AC_CHECK_FUNCS(strlcat strlcpy)