summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Dykstra <dwd@samba.org>1999-02-18 16:27:36 +0000
committerDavid Dykstra <dwd@samba.org>1999-02-18 16:27:36 +0000
commita8b9d4edec745757d34a10be0f6956c0609c2284 (patch)
tree34f22d245295eb9585002a2e345d2eb75514f804 /configure.in
parentf83f054875254ab48afaddcd8c985205ef9416e1 (diff)
downloadrsync-a8b9d4edec745757d34a10be0f6956c0609c2284.tar.gz
Changed exclude/include matching so that normally wildcards will stop at
slashes. The old behavior of crossing slashes can be achieved by using a double-asterisk ('**') anywhere in a pattern. Note that this can change some existing exclude patterns in a subtle way. Also note that if the remote side is an older release the processing on the two sides might not be exactly the same when there's no double-asterisk, which can affect which files are excluded from deletion, but they're close enough that people will probably not notice. I considered changing the protocol version and checking the remote_version number to ensure the same processing on both sides, but the exclude patterns are pre-processed before the remote version number is known and it's just not worth going through extraordinary efforts. Suggested by Cameron Simpson <cs@zip.com.au>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 25bf768c..11d6faec 100644
--- a/configure.in
+++ b/configure.in
@@ -56,7 +56,7 @@ AC_CHECK_FUNCS(strlcat strlcpy)
echo $ac_n "checking for working fnmatch... $ac_c"
AC_TRY_RUN([#include <fnmatch.h>
-main() { exit(fnmatch("*.o", "x.o", 0) == 0? 0: 1); }],
+main() { exit(fnmatch("*.o", "x.o", FNM_PATHNAME) == 0? 0: 1); }],
echo yes;AC_DEFINE(HAVE_FNMATCH),
echo no)