summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-05-06 06:07:06 +0000
committerAndrew Tridgell <tridge@samba.org>1998-05-06 06:07:06 +0000
commitefb2f6bf626c4379065431bc207b47a4b824a7f3 (patch)
tree9fee3e8e0b0de5e3ae1c937bd5879663a4ddf1ef /configure.in
parentbcacc18bdf1bdac625ef1f178e8e32892544cc30 (diff)
downloadrsync-efb2f6bf626c4379065431bc207b47a4b824a7f3.tar.gz
use floating point for printout of stats - this wrks on machines
without long long but with a 64 bit off_t
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6ffd78eb..511620af 100644
--- a/configure.in
+++ b/configure.in
@@ -52,7 +52,7 @@ echo no)
echo $ac_n "checking for long long ... $ac_c"
AC_TRY_RUN([#include <stdio.h>
-main() { long long x = 1000000; char b[20]; x *= x; sprintf(b,"%lld", x); exit(strcmp("1000000000000", b) == 0? 0: 1); }],
+main() { long long x = 1000000; x *= x; exit(((x/1000000) == 1000000)? 0: 1); }],
echo yes;AC_DEFINE(HAVE_LONGLONG),
echo no)