summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index edd72d45a..a9035eaa8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,6 @@ fi
AS=${AS-as}
AC_SUBST(AS)
if test "$GCC" = yes; then
- CFLAGS="$CFLAGS -fPIC -DPIC -D_REENTRANT -Wall -Wpointer-arith -Wmissing-prototypes -Wstrict-prototypes"
cflags_to_try="-fno-strict-aliasing -fstack-protector -Wempty-body"
AC_MSG_CHECKING([supported compiler flags])
old_cflags=$CFLAGS
@@ -50,7 +49,7 @@ if test "$GCC" = yes; then
],[])
CFLAGS=$old_cflags
done
- CFLAGS="$CFLAGS $RPMCFLAGS"
+ CFLAGS="$CFLAGS -fPIC -DPIC -D_REENTRANT -Wall -Wpointer-arith -Wmissing-prototypes -Wstrict-prototypes $RPMCFLAGS"
fi
export CFLAGS