summaryrefslogtreecommitdiff
path: root/rpmio/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2007-11-22 16:06:11 +0200
committerPanu Matilainen <pmatilai@redhat.com>2007-11-22 16:06:11 +0200
commite063854e118b92af3072e888e0887b2943187895 (patch)
tree03848d0a70e7aa585103f50146e9e16d323ae05d /rpmio/Makefile.am
parentb32cca34808e46bb5ce6972c99d95b3e53f555ab (diff)
downloadrpm-e063854e118b92af3072e888e0887b2943187895.tar.gz
Calculating file checksums aint legacy activity
- move the checksumming into librpmio - rename domd5() to rpmDoDigest() with future expansion for specifying digest algorithm type (ignored for now) - rearrange parameters to leave return types last - one less rpmio_internal outside rpmio/, whee... - used all over the rpm tree, and it knows about handling prelinked files so potentially useful for outside users, might as well export it - new public header rpmfilutil.h for collecting this sort of stuff
Diffstat (limited to 'rpmio/Makefile.am')
-rw-r--r--rpmio/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/rpmio/Makefile.am b/rpmio/Makefile.am
index 0149100cd..0510be0e6 100644
--- a/rpmio/Makefile.am
+++ b/rpmio/Makefile.am
@@ -15,7 +15,7 @@ librpmio_la_SOURCES = \
rpmhook.c rpmio.c rpmlog.c rpmlua.c rpmmalloc.c \
rpmpgp.c rpmrpc.c rpmsq.c rpmsw.c strcasecmp.c url.c ugid.c \
rpmio_internal.h rpmlua.h rpmhook.h ugid.h fts.h \
- rpmstring.c
+ rpmstring.c rpmfileutil.c
librpmio_la_LDFLAGS = -release 4.4
librpmio_la_LIBADD = \