summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2019-04-02 16:07:56 +0300
committerPanu Matilainen <pmatilai@redhat.com>2019-04-10 09:39:37 +0300
commitd48981ad7e36abb3500161d823acf92345c94f5d (patch)
treef03b704a1aeafa4ce2af2b3e7f79e86005bff20a /configure.ac
parent68d383c39cef8d58b80940b13dd132d3f41a03f0 (diff)
downloadrpm-d48981ad7e36abb3500161d823acf92345c94f5d.tar.gz
Support build-id generation from compressed ELF files (elfutils >= 0.175)
Use dwelf_elf_begin() for reading ELF files for build-id generation on versions that have it to support compressed ELF files such as kernel modules (RhBug:1650072,1650074). Note that debugedit still cannot handle compressed files, this is only for build-id generation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 99ce7df32..b2d7ed806 100644
--- a/configure.ac
+++ b/configure.ac
@@ -487,6 +487,10 @@ AS_IF([test "$WITH_LIBELF" = yes],[
# If possible we also want the strtab functions from elfutils 0.167.
# But we can fall back on the (unsupported) ebl alternatives if not.
AC_CHECK_LIB(dw, dwelf_strtab_init, [HAVE_LIBDW_STRTAB=yes])
+ # whether libdw supports compressed ELF objects
+ AC_CHECK_LIB(dw, dwelf_elf_begin, [
+ AC_DEFINE(HAVE_DWELF_ELF_BEGIN, 1, [Have dwelf_elf_begin?])
+ ])
])
])
])