summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNeal Gompa <ngompa13@gmail.com>2016-11-22 09:21:08 -0500
committerFlorian Festi <ffesti@redhat.com>2016-11-30 18:26:29 +0100
commitc04ff511a0d4692743326c49a934f92e0e3cadee (patch)
tree9fa262719bcae95ac291168550c28fb3cb4386aa /configure.ac
parentbde88ada3a0fbd17f9b5db9fb5426eb0f1ff5efd (diff)
downloadrpm-c04ff511a0d4692743326c49a934f92e0e3cadee.tar.gz
configure.ac: Support detecting gpg2 for %__gpg and prefer gpg2
For a number of years, various Linux distributions (notably Fedora and RHEL) have been overriding this to set it to use gnupg2, with no ill effects. Now that most distributions are switching to gnupg2 by default, we will, too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b4b3fe8fb..2eaf97ed5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,7 @@ AC_PATH_PROG(__CP, cp, /bin/cp, $MYPATH)
AC_PATH_PROG(__CPIO, cpio, /bin/cpio, $MYPATH)
AC_PATH_PROG(__CURL, curl, /usr/bin/curl, $MYPATH)
AC_PATH_PROG(__FILE, file, /usr/bin/file, $MYPATH)
-AC_PATH_PROG(__GPG, gpg, /usr/bin/gpg, $MYPATH)
+AC_PATH_PROGS(__GPG, gpg2 gpg, /usr/bin/gpg2, $MYPATH)
AC_PATH_PROG(__GREP, grep, /bin/grep, $MYPATH)
AC_PATH_PROG(__GZIP, gzip, /bin/gzip, $MYPATH)
AC_PATH_PROG(__UNZIP, unzip, /usr/bin/unzip, $MYPATH)