summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2012-08-14 08:44:32 +0300
committerPanu Matilainen <pmatilai@redhat.com>2012-08-14 08:44:32 +0300
commit789e258d6cf6f50c74af6c19579e90c7afed4b7c (patch)
tree491667e4d3131f34a8cd37023d2267c82a3ce57b /configure.ac
parente06177ee657fbb1c32e1f651c8ae4da73e87c65b (diff)
downloadrpm-789e258d6cf6f50c74af6c19579e90c7afed4b7c.tar.gz
Run gcc supported flags test without our stricter warning flags
- Fixes fallout from commit f9c69f803f74bd458269c7a06def494ea63387e6: running these tests with -Wstrict-prototypes causes all these tests to fail as AC_LANG_PROGRAM() uses an incomplete prototype for main() :(
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index edd72d45a..a9035eaa8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,6 @@ fi
AS=${AS-as}
AC_SUBST(AS)
if test "$GCC" = yes; then
- CFLAGS="$CFLAGS -fPIC -DPIC -D_REENTRANT -Wall -Wpointer-arith -Wmissing-prototypes -Wstrict-prototypes"
cflags_to_try="-fno-strict-aliasing -fstack-protector -Wempty-body"
AC_MSG_CHECKING([supported compiler flags])
old_cflags=$CFLAGS
@@ -50,7 +49,7 @@ if test "$GCC" = yes; then
],[])
CFLAGS=$old_cflags
done
- CFLAGS="$CFLAGS $RPMCFLAGS"
+ CFLAGS="$CFLAGS -fPIC -DPIC -D_REENTRANT -Wall -Wpointer-arith -Wmissing-prototypes -Wstrict-prototypes $RPMCFLAGS"
fi
export CFLAGS