summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2021-12-17 14:03:35 +0200
committerPanu Matilainen <pmatilai@redhat.com>2021-12-17 14:57:14 +0200
commitbf58cfd08f344872d30082c123a0035429d51742 (patch)
tree378d638002142004feb422c6698079dbf3e3a6a2 /Makefile.am
parent67280003444e25e42bbc97170e9b12a5d7fb1cc6 (diff)
downloadrpm-bf58cfd08f344872d30082c123a0035429d51742.tar.gz
Add rpmlua wrapper command for running our Lua interpreter standalone
Being able to run stuff easily in rpm context helps developing and debugging scriptlets and macros too. Supports running one-liner statements from the cli, regular scripts and an interactive session. This is placed into a separate executable for, well, separation and simplicity, but it'll also give us means to link to readline without dragging that to main rpm dependencies (but that's left for later).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c15fbb6c9..b0f3fcd49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -157,6 +157,11 @@ rpm2archive_SOURCES = rpm2archive.c debug.h system.h
rpm2archive_LDADD = lib/librpm.la rpmio/librpmio.la
rpm2archive_LDADD += @WITH_POPT_LIB@ @WITH_ARCHIVE_LIB@
+bin_PROGRAMS += rpmlua
+rpmspec_CPPFLAGS = $(AM_CPPFLAGS)
+rpmlua_SOURCES = tools/rpmlua.c debug.h system.h
+rpmlua_LDADD = lib/librpm.la rpmio/librpmio.la
+rpmlua_LDADD += @WITH_POPT_LIB@
if LIBELF
rpmlibexec_PROGRAMS += elfdeps