summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2021-01-29 13:01:48 +0200
committerFlorian Festi <ffesti@redhat.com>2021-02-03 14:41:48 +0100
commit4290300e24c5ab17c615b6108f38438e31eeb1d0 (patch)
tree346bda0e61a6cc466c5fb9d85a3af46dbbb44936 /Makefile.am
parentabb19a23b9386bb14ac38e65f0b6bdc6bd306ada (diff)
downloadrpm-4290300e24c5ab17c615b6108f38438e31eeb1d0.tar.gz
Remove support for Berkeley Database backend
Back in 2013, the Berkeley DB license was changed in a way that prevented most of open-source world to go along, rpm was no different. We now have other options and a standalone migration path from BDB for those that haven't yet done so. Whatever else might be said about this partnership, it has been a long one. Now's the time to part ways.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index aca2f8996..4ad38c36d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,13 +23,10 @@ AM_CFLAGS = @RPMCFLAGS@
CLEANFILES =
EXTRA_DIST = ChangeLog CREDITS INSTALL \
- autogen.sh db3/configure installplatform platform.in build-aux
+ autogen.sh installplatform platform.in build-aux
BUILT_SOURCES =
SUBDIRS = po misc
-if WITH_INTERNAL_DB
-SUBDIRS += db3
-endif
if WITH_LUA
SUBDIRS += luaext
endif
@@ -292,13 +289,6 @@ endif
EXTRA_DIST += doc/librpm.doxy.in doc/librpm/Doxyheader.h
EXTRA_DIST += doc/librpm/html
-if WITH_INTERNAL_DB
-db.h: $(top_builddir)/db3/db.h
- $(LN_S) $(top_builddir)/db3/db.h $@
-BUILT_SOURCES += db.h
-endif
-DISTCLEANFILES = db.h
-
.PHONY: ci
ci:
podman build -t rpm -f ci/Dockerfile .
@@ -316,7 +306,7 @@ clean-local:
distclean-local:
rm -rf doc/librpm.doxy doc/librpm/html
rm -rf Doxytags
- rm -f stamp-h.in db3/*.orig db3/db3lobjs
+ rm -f stamp-h.in
$(top_srcdir)/preinstall.am: Makefile.am
rm -f $(top_srcdir)/preinstall.am