summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChet Ramey <chet.ramey@case.edu>2011-11-23 18:39:33 -0500
committerChet Ramey <chet.ramey@case.edu>2011-11-23 18:39:33 -0500
commit06cd36cdc90634c88636a6d09230c573078ead0e (patch)
tree4975cd6dbfb74e0d8c04ceb6e77584edaec70d11 /configure.in
downloadreadline-06cd36cdc90634c88636a6d09230c573078ead0e.tar.gz
Readline-2.0 import: initial import
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 48 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..febcbab
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,48 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(readline.h)
+AC_CONFIG_HEADER(config.h)
+AC_REVISION(Configure for Readline 2.0)
+
+# We want these before the checks, so the checks can modify their values.
+test -z "$CFLAGS" && CFLAGS=-g auto_cflags=1
+
+AC_PROG_CC
+
+# If we're using gcc and the user hasn't specified CFLAGS, add -O to CFLAGS.
+test -n "$GCC" && test -n "$auto_cflags" && CFLAGS="$CFLAGS -O"
+
+AC_SUBST(CFLAGS)dnl
+AC_SUBST(LDFLAGS)dnl
+
+AC_GCC_TRADITIONAL
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+AC_USG
+
+AC_HAVE_FUNCS(strcasecmp sighold)
+
+AC_HAVE_HEADERS(unistd.h stdlib.h varargs.h string.h alloca.h \
+ dirent.h sys/ptem.h sys/pte.h sys/stream.h termcap.h \
+ termio.h)
+
+AC_HEADER_CHECK(sys/file.h, ,AC_DEFINE(NO_SYS_FILE))
+
+if test -z "$have_tiocgwinsz"; then
+AC_COMPILE_CHECK(TIOCGWINSZ in sys/ioctl.h,
+[#include <sys/types.h>
+#include <sys/ioctl.h>], [int x = TIOCGWINSZ;],
+AC_DEFINE(GWINSZ_IN_SYS_IOCTL))
+fi
+
+AC_COMPILE_CHECK(programs able to redeclare getpw functions,
+[#include <sys/types.h>
+#include <pwd.h>
+extern struct passwd *getpwuid();], [struct passwd *z; z = getpwuid(0);], ,
+AC_DEFINE(HAVE_GETPW_DECLS))
+
+AC_ALLOCA
+
+AC_OUTPUT(Makefile, [
+# Makefile uses this timestamp file to record whether config.h is up to date.
+touch stamp-config])