summaryrefslogtreecommitdiff
path: root/tests/auto/qx11info/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qx11info/CMakeLists.txt')
-rw-r--r--tests/auto/qx11info/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/qx11info/CMakeLists.txt b/tests/auto/qx11info/CMakeLists.txt
new file mode 100644
index 0000000..042e007
--- /dev/null
+++ b/tests/auto/qx11info/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Generated from qx11info.pro.
+
+# begin special case
+if(NOT TARGET XCB::XCB)
+ qt_find_package(XCB REQUIRED PROVIDED_TARGETS XCB::XCB)
+endif()
+# end special case
+
+#####################################################################
+## tst_qx11info Test:
+#####################################################################
+
+add_qt_test(tst_qx11info
+ SOURCES
+ tst_qx11info.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Widgets
+ Qt::X11Extras
+ XCB::XCB
+)