summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..1930dcb
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Generated from tests.pro.
+
+if(NOT TARGET Qt::Test)
+ cmake_minimum_required(VERSION 3.15.0)
+ project(QtX11ExtrasTests VERSION 6.0.0 LANGUAGES C CXX)
+ find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS BuildInternals Core Gui Widgets Test X11Extras) # special case
+ qt_set_up_standalone_tests_build()
+endif()
+
+find_package(Qt6 ${PROJECT_VERSION} COMPONENTS Widgets) # special case
+
+# special case begin
+if(QT_FEATURE_xcb)
+qt_build_tests()
+endif()
+# special case end