summaryrefslogtreecommitdiff
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-12-06 14:38:00 +0100
committerStephen Kelly <stephen.kelly@kdab.com>2012-12-07 11:17:02 +0100
commit7fab677324b13e254e3938c8fc70c8da181c1066 (patch)
treedfe0b55a4b04c47abb876671dfadfab6a2427aa8 /tests/auto/cmake/CMakeLists.txt
parent013061630c8076682f5db098821d18cf6a1c22a6 (diff)
downloadqtx11extras-7fab677324b13e254e3938c8fc70c8da181c1066.tar.gz
Add unit tests for the cmake files.
Change-Id: I2e07862e0e13d8a9747691d219185edbe6c86274 Reviewed-by: David Faure (KDE) <faure@kde.org>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
new file mode 100644
index 0000000..271ab54
--- /dev/null
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -0,0 +1,12 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(qmake_cmake_files)
+
+enable_testing()
+
+find_package(Qt5Core REQUIRED)
+
+include("${_Qt5CTestMacros}")
+
+expect_pass(test_qx11_module)