summaryrefslogtreecommitdiff
path: root/src/imports/qmlwebsockets/.prev_CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-09-19 13:59:47 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-09-19 12:19:49 +0000
commit5feeb5867d032cc4641ee088cfa5bd9063bcf5cd (patch)
treefdd2501d52bad45cb7bb149ba3077c1730147651 /src/imports/qmlwebsockets/.prev_CMakeLists.txt
parenta3c87a0e44bb67cc3f726dd915178f9f307480e8 (diff)
downloadqtwebsockets-5feeb5867d032cc4641ee088cfa5bd9063bcf5cd.tar.gz
Fix the cmake configuration step
Re-generate some CMakeLists.txt files to fix the build after the declarative cmake API changes. Change-Id: Ia2fadf066259bb0572ba35d3d16aec6aaae4d981 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'src/imports/qmlwebsockets/.prev_CMakeLists.txt')
-rw-r--r--src/imports/qmlwebsockets/.prev_CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/imports/qmlwebsockets/.prev_CMakeLists.txt b/src/imports/qmlwebsockets/.prev_CMakeLists.txt
new file mode 100644
index 0000000..aa1785d
--- /dev/null
+++ b/src/imports/qmlwebsockets/.prev_CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from qmlwebsockets.pro.
+
+#####################################################################
+## qmlwebsockets Plugin:
+#####################################################################
+
+add_qml_module(qmlwebsockets
+ URI "QtWebSockets"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtWebSocketsDeclarativeModule
+ SOURCES
+ qmlwebsockets_plugin.cpp qmlwebsockets_plugin.h
+ qqmlwebsocket.cpp qqmlwebsocket.h
+ qqmlwebsocketserver.cpp qqmlwebsocketserver.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::WebSockets
+)
+
+#### Keys ignored in scope 1:.:.:qmlwebsockets.pro:<TRUE>:
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir"
+# TARGETPATH = "QtWebSockets"
+# _LOADED = "qml_plugin"