summaryrefslogtreecommitdiff
path: root/chromium/third_party/protobuf/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'chromium/third_party/protobuf/python/setup.py')
-rwxr-xr-xchromium/third_party/protobuf/python/setup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/chromium/third_party/protobuf/python/setup.py b/chromium/third_party/protobuf/python/setup.py
index 8a986298664..fbe2766030c 100755
--- a/chromium/third_party/protobuf/python/setup.py
+++ b/chromium/third_party/protobuf/python/setup.py
@@ -26,9 +26,7 @@ from distutils.spawn import find_executable
maintainer_email = "protobuf@googlegroups.com"
# Find the Protocol Compiler.
-if 'PROTOC' in os.environ and os.path.exists(os.environ['PROTOC']):
- protoc = os.environ['PROTOC']
-elif os.path.exists("../src/protoc"):
+if os.path.exists("../src/protoc"):
protoc = "../src/protoc"
elif os.path.exists("../src/protoc.exe"):
protoc = "../src/protoc.exe"
@@ -156,7 +154,7 @@ if __name__ == '__main__':
libraries = [ "protobuf" ]))
setup(name = 'protobuf',
- version = '2.5.0-pre',
+ version = '2.4.2-pre',
packages = [ 'google' ],
namespace_packages = [ 'google' ],
test_suite = 'setup.MakeTestSuite',
@@ -167,7 +165,6 @@ if __name__ == '__main__':
'google.protobuf.internal.cpp_message',
'google.protobuf.internal.decoder',
'google.protobuf.internal.encoder',
- 'google.protobuf.internal.enum_type_wrapper',
'google.protobuf.internal.message_listener',
'google.protobuf.internal.python_message',
'google.protobuf.internal.type_checkers',