summaryrefslogtreecommitdiff
path: root/chromium/third_party/dav1d/libdav1d/src/meson.build
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2019-07-31 15:50:41 +0200
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2019-08-30 12:35:23 +0000
commit7b2ffa587235a47d4094787d72f38102089f402a (patch)
tree30e82af9cbab08a7fa028bb18f4f2987a3f74dfa /chromium/third_party/dav1d/libdav1d/src/meson.build
parentd94af01c90575348c4e81a418257f254b6f8d225 (diff)
downloadqtwebengine-chromium-7b2ffa587235a47d4094787d72f38102089f402a.tar.gz
BASELINE: Update Chromium to 76.0.3809.94
Change-Id: I321c3f5f929c105aec0f98c5091ef6108822e647 Reviewed-by: Michael BrĂ¼ning <michael.bruning@qt.io>
Diffstat (limited to 'chromium/third_party/dav1d/libdav1d/src/meson.build')
-rw-r--r--chromium/third_party/dav1d/libdav1d/src/meson.build38
1 files changed, 19 insertions, 19 deletions
diff --git a/chromium/third_party/dav1d/libdav1d/src/meson.build b/chromium/third_party/dav1d/libdav1d/src/meson.build
index 2487197247a..a2baedbd857 100644
--- a/chromium/third_party/dav1d/libdav1d/src/meson.build
+++ b/chromium/third_party/dav1d/libdav1d/src/meson.build
@@ -28,43 +28,43 @@
# libdav1d source files
libdav1d_sources = files(
- 'picture.c',
+ 'cdf.c',
'cpu.c',
'data.c',
- 'ref.c',
- 'log.c',
- 'getbits.c',
- 'obu.c',
'decode.c',
- 'cdf.c',
- 'msac.c',
- 'tables.c',
- 'scan.c',
'dequant_tables.c',
+ 'getbits.c',
'intra_edge.c',
'lf_mask.c',
+ 'log.c',
+ 'msac.c',
+ 'obu.c',
+ 'picture.c',
+ 'qm.c',
+ 'ref.c',
'ref_mvs.c',
+ 'scan.c',
+ 'tables.c',
'warpmv.c',
'wedge.c',
- 'qm.c',
)
# libdav1d bitdepth source files
# These files are compiled for each bitdepth with
# `BITDEPTH` defined to the currently built bitdepth.
libdav1d_tmpl_sources = files(
+ 'cdef_apply_tmpl.c',
+ 'cdef_tmpl.c',
+ 'film_grain_tmpl.c',
'ipred_prepare_tmpl.c',
'ipred_tmpl.c',
'itx_tmpl.c',
'lf_apply_tmpl.c',
'loopfilter_tmpl.c',
- 'mc_tmpl.c',
- 'cdef_apply_tmpl.c',
- 'cdef_tmpl.c',
- 'lr_apply_tmpl.c',
'looprestoration_tmpl.c',
+ 'lr_apply_tmpl.c',
+ 'mc_tmpl.c',
'recon_tmpl.c',
- 'film_grain_tmpl.c',
)
# libdav1d entrypoint source files
@@ -128,15 +128,15 @@ if is_asm_enabled
if dav1d_bitdepths.contains('8')
libdav1d_sources_asm += files(
'x86/cdef.asm',
- 'x86/cdef_sse.asm',
'x86/ipred.asm',
- 'x86/ipred_ssse3.asm',
'x86/itx.asm',
- 'x86/itx_ssse3.asm',
'x86/loopfilter.asm',
'x86/looprestoration.asm',
- 'x86/looprestoration_ssse3.asm',
'x86/mc.asm',
+ 'x86/cdef_sse.asm',
+ 'x86/ipred_ssse3.asm',
+ 'x86/itx_ssse3.asm',
+ 'x86/looprestoration_ssse3.asm',
'x86/mc_ssse3.asm',
)
endif