summaryrefslogtreecommitdiff
path: root/chromium/third_party/dav1d/libdav1d/doc/meson.build
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2022-05-12 15:59:20 +0200
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2022-05-25 06:57:22 +0000
commitf7eaed5286974984ba5f9e3189d8f49d03e99f81 (patch)
treecaed19b2af2024f35449fb0b781d0a25e09d4f8f /chromium/third_party/dav1d/libdav1d/doc/meson.build
parent9729c4479fe23554eae6e6dd1f30ff488f470c84 (diff)
downloadqtwebengine-chromium-f7eaed5286974984ba5f9e3189d8f49d03e99f81.tar.gz
BASELINE: Update Chromium to 100.0.4896.167
Change-Id: I98cbeb5d7543d966ffe04d8cefded0c493a11333 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'chromium/third_party/dav1d/libdav1d/doc/meson.build')
-rw-r--r--chromium/third_party/dav1d/libdav1d/doc/meson.build35
1 files changed, 18 insertions, 17 deletions
diff --git a/chromium/third_party/dav1d/libdav1d/doc/meson.build b/chromium/third_party/dav1d/libdav1d/doc/meson.build
index 0ef7123448a..363429f3712 100644
--- a/chromium/third_party/dav1d/libdav1d/doc/meson.build
+++ b/chromium/third_party/dav1d/libdav1d/doc/meson.build
@@ -1,4 +1,4 @@
-# Copyright © 2018, VideoLAN and dav1d authors
+# Copyright © 2018-2021, VideoLAN and dav1d authors
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -22,22 +22,23 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-doxygen = find_program('doxygen', required: false)
-dot = find_program('dot', required: false)
+if not get_option('enable_docs')
+ subdir_done()
+endif
-if doxygen.found() and dot.found()
- conf_data = configuration_data()
- conf_data.set('DOXYGEN_INPUT', join_paths(dav1d_src_root, 'include/dav1d'))
- conf_data.set('DOXYGEN_STRIP', join_paths(dav1d_src_root, 'include'))
- conf_data.set('DOXYGEN_OUTPUT', meson.current_build_dir())
- doxyfile = configure_file(input: 'Doxyfile.in',
- output: 'Doxyfile',
- configuration: conf_data)
+doxygen = find_program('doxygen')
+dot = find_program('dot')
- custom_target('doc',
- build_by_default: false,
- command: [doxygen, doxyfile],
- output: ['html']
- )
-endif
+conf_data = configuration_data()
+conf_data.set('DOXYGEN_INPUT', dav1d_src_root / 'include/dav1d')
+conf_data.set('DOXYGEN_STRIP', dav1d_src_root / 'include')
+conf_data.set('DOXYGEN_OUTPUT', meson.current_build_dir())
+doxyfile = configure_file(input: 'Doxyfile.in',
+ output: 'Doxyfile',
+ configuration: conf_data)
+custom_target('doc',
+ build_by_default: false,
+ command: [doxygen, doxyfile],
+ output: ['html']
+)