summaryrefslogtreecommitdiff
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 1d588ac..f912bf0 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -9,6 +9,10 @@ find_package(Qt5Core REQUIRED)
include("${_Qt5CTestMacros}")
+# Qt5Qml is an optional dependency of QWebChannel headers. Make sure we find it
+# in the test.
+set(Qt5_MODULE_TEST_DEPENDS Qml)
+
test_module_includes(
WebChannel QWebChannel
)