summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 0653827..fd61af0 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1 +1,11 @@
-add_subdirectory(auto)
+# special case begin
+if(NOT TARGET Qt::Test)
+ cmake_minimum_required(VERSION 3.14.0)
+ project(QtSvgTests C CXX ASM)
+ find_package(Qt5 REQUIRED COMPONENTS BuildInternals Core Test)
+ find_package(Qt5 COMPONENTS Svg Widgets Xml)
+ qt_set_up_standalone_tests_build()
+endif()
+# special case end
+
+qt_build_tests()