summaryrefslogtreecommitdiff
path: root/tests/auto/qsvgrenderer/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kfunk@kde.org>2019-02-13 12:59:44 +0100
committerKevin Funk <kevin.funk@kdab.com>2019-05-03 13:50:55 +0000
commit775922d2315dddcd2750acf5d3a8a90d368dc000 (patch)
tree8013bea5d1939cc6de8830f7209dc0c3c964d7ef /tests/auto/qsvgrenderer/CMakeLists.txt
parentd0cba8947e5261dff56cb379d7462855d1eb7263 (diff)
downloadqtsvg-775922d2315dddcd2750acf5d3a8a90d368dc000.tar.gz
cmake: Initial CMake build system support
Task-number: QTBUG-74135 Done-With: Alexandru Croitor <alexandru.croitor@qt.io> Done-With: Liang Qi <liang.qi@qt.io> Change-Id: I81fdc3d06f53e78182352214ef4687924dfc6fb6 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/qsvgrenderer/CMakeLists.txt')
-rw-r--r--tests/auto/qsvgrenderer/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/auto/qsvgrenderer/CMakeLists.txt b/tests/auto/qsvgrenderer/CMakeLists.txt
new file mode 100644
index 0000000..38932a0
--- /dev/null
+++ b/tests/auto/qsvgrenderer/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from qsvgrenderer.pro.
+
+#####################################################################
+## tst_qsvgrenderer Test:
+#####################################################################
+
+add_qt_test(tst_qsvgrenderer
+ SOURCES
+ tst_qsvgrenderer.cpp
+ DEFINES
+ SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/./\\\"
+ LIBRARIES
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Svg
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(tst_qsvgrenderer "resources" FILES
+ heart.svgz)
+
+
+#### Keys ignored in scope 1:.:.:qsvgrenderer.pro:<TRUE>:
+# CONFIG = "testcase"