summaryrefslogtreecommitdiff
path: root/examples/serialport/slave/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 17:47:07 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 12:24:09 +0000
commit4131118d849ef01c5a1f10ac0791088aec11b269 (patch)
treee05630c1e27d20d9e118a9a0b6f9b1e77a75f130 /examples/serialport/slave/CMakeLists.txt
parent2e27d1967a9a4146697028ed8feed14d0df2a46a (diff)
downloadqtserialport-4131118d849ef01c5a1f10ac0791088aec11b269.tar.gz
Regenerate projectswip/cmake
Change-Id: I67f250ddeeff247effde641ea3059e62fa67971a Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/serialport/slave/CMakeLists.txt')
-rw-r--r--examples/serialport/slave/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/examples/serialport/slave/CMakeLists.txt b/examples/serialport/slave/CMakeLists.txt
index ce86337..ca819f4 100644
--- a/examples/serialport/slave/CMakeLists.txt
+++ b/examples/serialport/slave/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/serialport/slave")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -23,6 +23,13 @@ target_link_libraries(slave PUBLIC
Qt::Gui
)
+if((QT_MAJOR_VERSION GREATER 4))
+ target_link_libraries(slave PUBLIC
+ Qt::SerialPort
+ Qt::Widgets
+ )
+endif()
+
install(TARGETS slave
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"