summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDoris Verria <doris.verria@qt.io>2021-01-19 14:15:42 +0100
committerLars Knoll <lars.knoll@qt.io>2021-01-28 14:11:46 +0000
commitd4ab8c60a9ace4ca56d0babc7594fecaf17d9eab (patch)
treede697ffae093630c4c2858f82be8968f6f0e5f6c /CMakeLists.txt
parent79b6a7e5df28c7b2dbbf1270ce2f5a6b3d184fac (diff)
downloadqtmultimedia-d4ab8c60a9ace4ca56d0babc7594fecaf17d9eab.tar.gz
Add find modules for 3rd party libraries and fix CMake files
Detect gstreamer, avfoundation, pulseaudio, alsa, mmrenderer and wmf with cmake. Regenerate and adjust configure.cmake and CMakeLists.txt files accordingly. Change-Id: I550136909498d3870e0babd6294652774a718f64 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e6ed4476..2d128888d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,8 +11,8 @@ project(QtMultimedia
)
# special case begin
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Network)
-# find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS SET_ME_TO_SOMETHING_USEFUL)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets Quick Qml OpenGL OpenGLWidgets QuickTest)
# special case end
if(NOT TARGET Qt::Gui)