summaryrefslogtreecommitdiff
path: root/src/3rdparty/poly2tri/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-08-09 18:03:50 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-08-10 12:34:29 +0000
commitc7f9592f9b063750b39b986d849d3bc9e328670c (patch)
treeec16a9848780a9952ee7796cca7991226aa07a0e /src/3rdparty/poly2tri/CMakeLists.txt
parentacf09bfcb9fbeb57506583203a81b64616186ba4 (diff)
downloadqtlocation-c7f9592f9b063750b39b986d849d3bc9e328670c.tar.gz
Fix static build
This patch fixes the "Bundled_Clip2Tri not found" error during static QtPositioning build. Fix backend plugins so that they get automatically linked in static build. Fixes: QTBUG-95582 Change-Id: Iea31c23a055689d9b8f6471345558b330795f597 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit 5c91b37a5b592c4c062f4386d83653c2170d1c07) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'src/3rdparty/poly2tri/CMakeLists.txt')
-rw-r--r--src/3rdparty/poly2tri/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/3rdparty/poly2tri/CMakeLists.txt b/src/3rdparty/poly2tri/CMakeLists.txt
index 083a98cd..167485db 100644
--- a/src/3rdparty/poly2tri/CMakeLists.txt
+++ b/src/3rdparty/poly2tri/CMakeLists.txt
@@ -18,6 +18,7 @@ qt_internal_add_3rdparty_library(Bundled_Poly2Tri
sweep/sweep_context.cpp sweep/sweep_context.h
)
qt_disable_warnings(Bundled_Poly2Tri)
+qt_set_symbol_visibility_hidden(Bundled_Poly2Tri)
## Scopes:
#####################################################################