summaryrefslogtreecommitdiff
path: root/src/3rdparty/poly2tri/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-01-06 17:37:02 +0100
committerIvan Solovev <ivan.solovev@qt.io>2021-01-20 14:10:41 +0100
commit65ce5e64aa549c536d36d6ae9c18ffd8c8eee0d6 (patch)
tree7d0e6db8287908336e9b0075bcc7bef0c1ed1660 /src/3rdparty/poly2tri/CMakeLists.txt
parent89f1e45e487ca6ae3998699153b10c343aef25d9 (diff)
downloadqtlocation-65ce5e64aa549c536d36d6ae9c18ffd8c8eee0d6.tar.gz
QtPositioning: port to cmake
Switching QtPositioning, its tests and examples to cmake. QtLocation is not covered by this patch. Task-number: QTBUG-89854 Change-Id: Ic971f7fd4c576eac9b662641aae77d68c062712d Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'src/3rdparty/poly2tri/CMakeLists.txt')
-rw-r--r--src/3rdparty/poly2tri/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/3rdparty/poly2tri/CMakeLists.txt b/src/3rdparty/poly2tri/CMakeLists.txt
new file mode 100644
index 00000000..083a98cd
--- /dev/null
+++ b/src/3rdparty/poly2tri/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from poly2tri.pro.
+
+#####################################################################
+## Bundled_Poly2Tri Generic Library:
+#####################################################################
+
+qt_internal_add_3rdparty_library(Bundled_Poly2Tri
+ QMAKE_LIB_NAME _poly2tri
+ STATIC
+ SKIP_AUTOMOC # special case
+ SOURCES
+ common/shapes.cpp common/shapes.h
+ common/utils.h
+ poly2tri.h
+ sweep/advancing_front.cpp sweep/advancing_front.h
+ sweep/cdt.cpp sweep/cdt.h
+ sweep/sweep.cpp sweep/sweep.h
+ sweep/sweep_context.cpp sweep/sweep_context.h
+)
+qt_disable_warnings(Bundled_Poly2Tri)
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 3:.:.:poly2tri.pro:GCC:
+# QMAKE_CFLAGS_OPTIMIZE_FULL = "-ffast-math"
+
+#### Keys ignored in scope 4:.:.:poly2tri.pro:NOT CLANG AND NOT ICC AND NOT rim_qcc:
+# QMAKE_CXXFLAGS_WARN_ON = "-Wno-error=return-type"