summaryrefslogtreecommitdiff
path: root/test/map
Commit message (Collapse)AuthorAgeFilesLines
* [android] add support for gnustlKonstantin Käfer2018-09-111-2/+4
|
* [core] Replace remaining dynamic_cast with static_castBruno de Oliveira Abinader2018-08-081-1/+1
|
* [core] Check all bucket dynamic_castsJohn Firebaugh2018-07-241-0/+49
| | | | A mismatch can occur when a layer changes from one type to another.
* Add pitch argument to cameraThatFits functions (#12213)Bobby Sudekum2018-07-021-2/+30
|
* [test] Update Map.PrefetchTilesBruno de Oliveira Abinader2018-02-282-61/+25
|
* [core] continue loading style even if we mutate itKonstantin Käfer2018-02-231-5/+16
| | | | When we load a stale style from cache, and the user immediately starts mutating it, we should continue loading the style so that we'll get a fresh copy of the data into our cache and avoid perpetually showing the stale style.
* [core] Split MapMode::Still into Static and TileAnsis Brammanis2017-11-172-3/+3
| | | | | `Tile` makes sure the symbols in the resulting tile are tileable while symbols in `Still` match rendering in `Continuous` mode.
* [core] Add `cameraForLatLngs()` method with modified bearingAsheem Mamoowala2017-10-091-0/+26
|
* [test] add test for rendering a 204 No Content tileKonstantin Käfer2017-09-221-0/+42
|
* [test] Added Map.SetStyleDefaultCamera testBruno de Oliveira Abinader2017-08-111-0/+15
|
* [node, tests] Consolidate headless rendering logic in HeadlessFrontendJohn Firebaugh2017-07-262-68/+42
|
* [test] allow only a single shared display to avoid egl errorsIvo van Dongen2017-07-182-3/+4
|
* [core] rename backend to renderer backendIvo van Dongen2017-07-182-2/+2
|
* [core] renderer interfaceIvo van Dongen2017-07-182-184/+166
|
* [core] split backend from mapobserverIvo van Dongen2017-07-182-61/+51
|
* [tests] Add unit test for tile prefetchingThiago Marcos P. Santos2017-07-071-0/+93
|
* [core] Check if frameZoom is NaN in Transform::flyTo callbackBruno de Oliveira Abinader2017-06-281-0/+5
|
* [core] Clamp to scale boundaries in TransformState::setLatLngZoomBruno de Oliveira Abinader2017-06-281-0/+16
|
* [core] fix render doesn’t flag style mutationIvo van Dongen2017-06-261-0/+26
|
* [core] Move setStyleJSON/URL to Style; add Map::setStyleJohn Firebaugh2017-06-221-24/+22
|
* [all] Promote Style to public APIJohn Firebaugh2017-06-221-49/+8
|
* [tests] Add tests for MapObserver::on{WillStart,DidFinish}LoadingMapJohn Firebaugh2017-06-221-0/+50
|
* [core] Make TransformState LatLngBounds optionalBruno de Oliveira Abinader2017-06-011-3/+7
|
* [core, node, darwin, android, qt] Make image ID part of ImageJohn Firebaugh2017-05-161-8/+8
| | | | More like Source and Layer.
* [core, node, darwin, qt] Remove support for paint classesJohn Firebaugh2017-05-151-34/+0
|
* [core] Split style image collection from SpriteAtlasIvo van Dongen2017-05-121-1/+1
|
* [all] Rationalize style::ImageJohn Firebaugh2017-04-241-5/+5
| | | | | | | A style has a collection of images, just as it has collections of sources and layers. * Name things appropriately * Use std::unique_ptr
* [android] use AAssetManager instead of libzipKonstantin Käfer2017-04-241-12/+0
|
* [core] Ignore shortest path in Map::pixelForLatLngBruno de Oliveira Abinader2017-04-142-25/+54
|
* [core] Tighten geo.hpp ctorsBruno de Oliveira Abinader2017-04-141-4/+2
|
* [all] Remove redundant scale-related camera methodsJohn Firebaugh2017-04-131-49/+27
| | | | We don't need to have two different measurement systems for map zoom.
* [core] Added {set,get}{Min,Max}PitchBruno de Oliveira Abinader2017-04-111-0/+18
|
* [core] Added Map::{get,set}LatLngBoundsBruno de Oliveira Abinader2017-04-111-0/+39
|
* [core] Updated Size::isEmpty and TransformState::valid checksBruno de Oliveira Abinader2017-04-101-23/+58
|
* [all] Make LatLng coordinates read-onlyJohn Firebaugh2017-04-062-114/+114
|
* [core] Tighten LatLng and other geo.hpp classesJohn Firebaugh2017-04-061-45/+1
| | | | | * Remove LatLng::null and enforce invariants * Remove unnecessary operator bool()
* [android] - update VectorSource javadoc (#8521)Tobrun2017-03-241-4/+3
| | | | | | * [android] - update VectorSource docs on VectorSource creation * [tests] Test only CameraOptions center, zoom in CameraToLatLngBounds
* [core] Added Map::latLngBoundsForCameraBruno de Oliveira Abinader2017-03-241-0/+22
|
* [core] Ensure that a BackendScope exists when doing GL callsKonstantin Käfer2017-03-231-1/+3
|
* [core] Pass std::exception_ptr in MapObserver::onDidFailLoadingMapBruno de Oliveira Abinader2017-03-171-21/+13
|
* [core] Replace MapChange enum with MapObserverBruno de Oliveira Abinader2017-03-152-27/+45
|
* [core] private OffscreenView implementationKonstantin Käfer2017-02-271-22/+22
|
* [core] Eliminate manual HeadlessBackend activation managementJohn Firebaugh2017-02-201-0/+2
|
* [core] Restore support for GL implementations without VAO extensionJohn Firebaugh2017-02-101-0/+19
|
* [test] Added unit test for style request failuresThiago Marcos P. Santos2017-02-071-0/+48
|
* [core] remove trailing whitespace, add trailing newlines, add space after //Konstantin Käfer2017-01-272-4/+4
|
* [core, ios] replace `altitude` with `fov`Ansis Brammanis2016-12-211-7/+7
| | | | | | | | | ported from -js: eb6c6596c6a7a61363d30356674e0002153b1d19 `altitude` was a terribly-named variable that was used to indirectly control the fov. This should eliminate some confusion. `altitude` was equivalent to `cameraToCenterDistance / height`
* Merge branch 'release-ios-v3.4.0' into 1ec5-release-ios-v3.4.0-beta.5-masterMinh Nguyễn2016-12-201-0/+12
|\ | | | | | | Also reran make style-code and manually discarded anything related to fill extrusion layers.
| * [test] Fixed Map-GetImageMinh Nguyễn2016-12-051-1/+1
| | | | | | | | Followup to #7096.
| * [core, ios, macos] Add image accessor to MGLStyle (#7096)Roman Blum2016-12-051-0/+12
| | | | | | | | | | | | | | | | | | | | | | | | * [core] Add interface to get image from sprite atlas * [tests] Add tests for Map::getImage * [ios, macos] WIP: get MGLImage for name from style * [ios, macos] Fixed -imageForName: Convert from sprite images to platform images using the existing encodePNG() function, which is also used for printing. Allow -imageForName: to return nil without an assertion failure. Added a basic test.