summaryrefslogtreecommitdiff
path: root/include/mbgl/util
Commit message (Collapse)AuthorAgeFilesLines
* [core] Fix performance-noexcept-move-constructor in header filesThiago Marcos P. Santos2020-04-172-10/+6
| | | | As reported by clang-tidy-8.
* [core] Fix readability-container-size-empty errors in header filesThiago Marcos P. Santos2020-04-171-1/+1
| | | | As reported by clang-tidy-8.
* [core] Fix readability-redundant-smartptr-get errors in header filesThiago Marcos P. Santos2020-04-171-3/+1
| | | | As reported by clang-tidy-8.
* [core] Fix readability-redundant-declaration errors in header filesThiago Marcos P. Santos2020-04-171-0/+4
| | | | As reported by clang-tidy-8.
* [core] Fix modernize-return-braced-init-list errors in header filesThiago Marcos P. Santos2020-04-173-15/+8
| | | | As reported by clang-tidy-8.
* [core] Fix performance-unnecessary-value-param errors in header filesThiago Marcos P. Santos2020-04-171-2/+2
| | | | As reported by clang-tidy-8.
* [core] Fix readability-redundant-member-init errors in header filesThiago Marcos P. Santos2020-04-171-2/+1
| | | | As reported by clang-tidy-8.
* [core] Fix readability-avoid-const-params-in-decls errors in header filesThiago Marcos P. Santos2020-04-172-2/+2
| | | | As reported by clang-tidy-8.
* Make location indicator bearing a paint propertyGali Nelle2020-04-081-2/+24
| | | | | | This change introduces a new property type, Rotation, that uses a custom interpolator, and that is currently applied to all style properties named "bearing", with a period attribute.
* [core] Move logging off the main threadJuha Alanen2020-04-011-1/+15
|
* [core] Fix modernize-pass-by-value errorsThiago Marcos P. Santos2020-03-231-13/+4
| | | | As reported by clang-tidy-8.
* Bump mapbox-base to 1.2.0Alexander Shalamov2020-03-231-1/+1
|
* [core] Fix performance-unnecessary-value-param errorsThiago Marcos P. Santos2020-03-231-1/+1
| | | | As reported by clang-tidy-8.
* [core] Follow-up on the platform integration callback PRThiago Marcos P. Santos2020-03-121-5/+6
| | | | Addressing review comments that arrived after the PR was merged.
* [core] Add a callback for platform RunLoop integrationThiago Marcos P. Santos2020-03-111-0/+12
| | | | | | | | Platform integration callback for platforms that do not have full run loop integration or don't want to block at the Mapbox GL Native loop. It will be called from any thread and is up to the platform to, after receiving the callback, call RunLoop::runOnce() from the same thread as the Map object lives.
* [core] Fix mbgl::Pass constructorMikhail Pozdnyakov2020-02-261-1/+1
|
* [core] Move mbgl::Pass and mbgl::PassRefPtr to a separate headerMikhail Pozdnyakov2020-02-261-0/+24
|
* [core] Fix Color serializationAlexander Shalamov2020-02-261-0/+1
|
* [core] Add hooks for setting experimental thread priorities for mbgl threadsAlexander Shalamov2020-02-061-15/+23
|
* [core] Add platform::setCurrentThreadPriority(double)Alexander Shalamov2020-02-061-0/+4
|
* [core] Add stretches and content to style::ImageKonstantin Käfer2020-01-151-3/+3
|
* [core] Modularize FileSource codebase (#15768)Alexander Shalamov2020-01-131-0/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * [core] Introduce FileSourceManager and use it for default platform impl - Add `FileSourceManager` interface that provides access to `FileSource` instances and means of registering / unregistering `FileSource` factories - Split `DefaultFileSource` into smaller parts - Add `DatabaseFileSource` interface and it's default implementation - Remove inter-dependencies between concrete `FileSource` classes * [build] Add files to next build system * [core] Add generic property setters / getters * [core] Remove setOnlineStatus from OnlineFileSource interface * [core] Hide threading implementation details from DatabaseFileSource interface * [core] Make DB file source methods virtual * [core] Add documentation for DatabaseFileSource and rename one method * [core] Use simple callback instead of ActorRef * [core] Remove ActorRef from OnlineFileSource public header * [core] Add callback to FileSource::forward async API * [core] Pass OfflineRegionDefinition by value * [core] Update tests to use modular file sources * [core] Update unit tests * [core] Update unit tests after rebase * [core] Backport low prio fix for cached requests * [core] Backport pack database * [core] Return removed factory from unRegisterFileSourceFactory * [core] Rename shadowed args in onlinefilesource * [core] Remove simple std::function callback aliases * [core] Expose online file source property keys in public header file * [test-runner] Add proxy file source test runner * [cache] Update mbgl-cache utility to use new file source * [metrics] Rebaseline binary size metrics * [offline] Update offline utility * [core] Update changelog
* [core] Fix MapSnapshotter build failure on WindowsAnder Conselvan de Oliveira2019-11-131-7/+2
| | | | | | | | MSVC implementation of std::promise is buggy and only works with types that can be default-constructed. To avoid a compilation failure in the instantiation of ask() inside MapSnapshotter::getRegion(), which creates a std::promise<LanLngBounds>, make LatLngBounds' default constructor public.
* [core] Use expected.hpp from mapbox-baseMikhail Pozdnyakov2019-11-081-1/+1
|
* [core,android,darwin,qt] Add fields related to feature-stateJuha Alanen2019-10-281-1/+15
| | | | | Move the fields from geometry.hpp/feature.hpp as they are not part of the GeoJSON specification.
* [render-test] Implement fps benchmarking tests (#15803)Mikko Pulkki2019-10-221-0/+24
|
* [core] Introduce Scheduler::makeWeakPtr()Mikhail Pozdnyakov2019-10-091-0/+2
|
* [core] Decouple Scheduler interface from actor modelMikhail Pozdnyakov2019-10-041-6/+2
| | | | So that it is possible to schedule normal `std::function` and use `mapbox::base::WeakPtr`.
* [core] ValueFactory for `expression::formatted`, other improvementsMikhail Pozdnyakov2019-09-271-0/+10
|
* [core] type aliases and conversion traits for mapbox::base::ValueMikhail Pozdnyakov2019-09-261-5/+5
|
* [core][android][darwin] Move number format to i18nAlexander Shalamov2019-09-261-3/+0
|
* [core] Fix performance-move-const-argThiago Marcos P. Santos2019-09-253-14/+7
|
* [build] Fix clang format and tidy checksJuha Alanen2019-09-181-16/+4
|
* [core] Add feature state support to bucket classesJuha Alanen2019-09-181-0/+24
|
* [core] Add new types for feature statesJuha Alanen2019-09-181-0/+3
|
* [build] Fix clang format and tidy checksThiago Marcos P. Santos2019-09-172-5/+10
|
* [build] Mark explicitly visible symbolsThiago Marcos P. Santos2019-09-171-0/+21
| | | | | Easier to maintain than a linker script. We build everything with visibility hidden by default.
* [build] Make the default styles part of GL NativeThiago Marcos P. Santos2019-09-171-0/+30
| | | | | The reason is applications using it, like GLFW, don't need to depend on code inside platform/default.
* [core] Bitmask operations for enumsMikhail Pozdnyakov2019-09-131-0/+33
|
* [core] Use mapbox::base::TypeWrapper instead of utils::peerMikhail Pozdnyakov2019-09-101-34/+0
|
* [core][node] Serialize formatted expression's text-color optionAlexander Shalamov2019-08-151-0/+2
| | | | This enables proper round-tripping for serialized format expression.
* [core] Limit pitch based on edge insets. Fix max Z calculation in getProjMatrix.Aleksandar Stojiljkovic2019-08-011-1/+1
| | | | | | | | | | | | | Patch partly fixes #15163 in a way that it doesn't allow loading tens of thousands of tiles and attempt to show area above horizon: Limit pitch based on edge insets. It is not too bad - current limit of 60 degrees stays active until center of perspective is moved towards the bottom, to 84% of screen height. The plan is to split removal of 60 degrees limit to follow up patch. Fix max Z calculation in getProjMatrix. TransformState::getProjMatrix calculation of farZ was complex with possibility to lead to negative z values. Replacing it with simpler, precise calculation: furthestDistance = cameraToCenterDistance / (1 - tanFovAboveCenter * std::tan(getPitch())); TransformState::getProjMatrix calculation of farZ was an aproximation. Replacing it with simpler, but precise calculation. Related to: #15163
* [core] Add number-format expressionJuha Alanen2019-06-271-0/+3
|
* [build] remove roundtrip through <experimental/optional> when using optionalKonstantin Käfer2019-06-121-1/+1
|
* [core] remove platform::show(Color)?DebugImageKonstantin Käfer2019-05-281-6/+0
|
* [core] limit thread's scope to release the Object before detaching the threadŁukasz Paczos2019-05-241-11/+15
|
* [core] option to perform platform specific operations when ↵Łukasz Paczos2019-05-221-0/+3
| | | | creating/destroying core threads
* [core] RenderLayer::render(PaintParameters, RenderSource*) -> ↵Mikhail Pozdnyakov2019-05-221-0/+2
| | | | render(PaintParameters)
* [core] Define max cache size for ImageManagerAlexander Shalamov2019-05-211-0/+4
|
* [core] use unique IDs for DrawScopesKonstantin Käfer2019-05-151-1/+2
|