summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* [core] make the offline DB schema a regular include fileupstream/make-offline-schema-a-regular-include-headerKonstantin Käfer2018-07-164-25/+31
|
* [core] Convert legacy functions directly to expressionsJohn Firebaugh2018-07-1322-1190/+774
|
* [build] Use CIRCLE_MERGE_BASE environment variableJohn Firebaugh2018-07-131-22/+5
|
* [build] Show diff to prior sizeJohn Firebaugh2018-07-131-14/+67
|
* [build] Reduce ccache max sizeJohn Firebaugh2018-07-131-1/+1
|
* [build] Improve ccache freshnessJohn Firebaugh2018-07-132-30/+118
| | | | | | | | | | | | | | | | | | | | Save a fresh ccache on every build by including (a checksum of) the current revision in the cache key. In the worst case, saving the cache appears to take ~1:30 for android-release; other builds appear to take a small amount of time compared to the time saved by having a fresh cache, versus a cache that's up to a week old. Restore caches in the following priority order (all scoped to current architecture and job): 1. The cache for the current branch and revision. 2. If that doesn't exist, the most recent cache for the current branch. 3. If that doesn't exist, the cache for the parent branch and merge base, where "parent branch" means the base branch of the pull request specified by $CIRCLE_PULL_REQUEST (obtained from the GitHub API), and "merge base" means the revision returned by `git merge-base` when given the parent branch and $CIRCLE_BRANCH (obtained by executing that shell command). The intent here is to start a newly created branch off with the most relevant cache from its parent branch. 4. If that doesn't exist, the most recent cache for the parent branch. 5. If that doesn't exist, the most recent cache for master. 6. If that doesn't exist, use the most recent cache for any build. We cannot use the branch names or revisions themselves as key segments, because CircleCI lacks a way to interpolate arbitrary environment variables into the cache key name. Instead, we write the desired value into a file and use the `{{ checksum "filename" }}` syntax.
* [build] Separate node_modules, mason_packages, and cmake cachesJohn Firebaugh2018-07-131-92/+202
|
* [build] Move all mason_use statements to a single fileJohn Firebaugh2018-07-137-57/+67
| | | | So its checksum can be used in a CI cache key name.
* [android] - add geojson regression tests for java method look up from JNItobrun2018-07-131-13/+103
|
* [node] prevent scheduled renderFinished() calls from running when render is ↵Konstantin Käfer2018-07-131-9/+16
| | | | | | | | | | | | | | | | | canceled Reverts d5aff71 (#11948) and implements an alternative solution. Even with the previous fix applied, we were calling `renderFinished()` directly when the render was canceled. This led to the following scenario (all on the main thread): - `Map::renderStill()` callback is called, `uv_async_send` schedules a call to `renderFinished()`. - `NodeMap::cancel()` destroys the map object, and calls `renderFinished()` directly, which cleans up the request - `NodeMap::startRender()` is called to schedule a _new_ render, which means that a new callback will be set - The `uv_async_t` fires and calls `renderFinished` again: - We don't return early as intended by the fix in #11948 since a new callback/`req` object is now available. - Since neither error nor image has been set, we'll see a `Didn't get an image` error message. - We call the callback with the error. In scenario where we're reusing Map objects, we will start a new render, which will now trigger the `Map is currently rendering an image` error in `Map::renderStill`, and the map object enters a circle in which it will now fail repeatedly with this error. This commit fixes the issue by completely removing the existing `uv_async_t` handle that could have a scheduled call, and replacing it with a fresh instance of an `uv_async_t` handle.
* [core] Simplify Value conversionsJohn Firebaugh2018-07-122-107/+42
| | | | | | Use a single template function for each of {to,from}ExpressionValue, always dispatching to ValueConverter. Remove unused ValueConverter::ExpressionType typedefs.
* [android] - add convenience method for destroyed state on MapView, can be ↵tobrun2018-07-123-4/+19
| | | | used to determine if an asynchrous result should be set on map.
* [android] - validate if gesture detector is able to handle gesturetobrun2018-07-121-2/+6
|
* [ios] Adjust iOS nightly build to run laterJason Wray2018-07-111-1/+1
| | | | | CircleCI’s cron jobs run on UTC, while their containers are set to US-Pacific. This change pushes back the `nightly` workflow from 12AM UTC (5PM PDT) to 5AM UTC (10PM PDT). /cc @julianrex @fabian-guerra
* [ios] Update podspecs for ios-v4.2.0-beta.1Jason Wray2018-07-113-3/+3
|
* [ios] Update events submodule to include RN override (#12360)Randall Lee2018-07-101-0/+0
| | | React native user agent override for internal use.
* [ios, build] Upload nightly iOS release build on CircleCIJason Wray2018-07-101-8/+24
|
* [macos] Import GeoJSONMinh Nguyễn2018-07-104-15/+111
| | | | Added an Import command to the File menu for adding the contents of a GeoJSON file to the map. simplestyle-spec formatting is applied to layers via a handful of expressions. Dropped pins include any details provided through simplestyle-spec properties.
* [ios] Deduplicated library dependency referencesMinh Nguyễn2018-07-101-18/+8
|
* [ios, macos] Allow unwrapped arguments in match expressionsMinh Nguyễn2018-07-094-5/+18
|
* [ios, macos] Convert predicate options to collatorsMinh Nguyễn2018-07-0910-28/+149
|
* [core] Comparison expressions can have 4th memberMinh Nguyễn2018-07-091-1/+1
| | | | When detecting an expression used as a filter, relax the check for expressions to allow comparison expressions to contain a fourth member for the collator.
* [qt, build] Rename Qt builds to follow conventionJason Wray2018-07-091-66/+66
| | | | CI job naming convention is: <platform>-<optional-descriptor>-<buildtype>
* [node, build] Rename Node builds to follow conventionJason Wray2018-07-091-29/+29
| | | | CI job naming convention is: <platform>-<optional-descriptor>-<buildtype>
* [glfw] Use Map::moveBy in GLFWView::onMouseMoveBruno de Oliveira Abinader2018-07-091-5/+3
|
* [core] Harden Projection::project()Bruno de Oliveira Abinader2018-07-092-1/+45
|
* [ios, build] Strip symbols before recording size metricsJason Wray2018-07-091-1/+2
|
* [android] - bumped telemetry to v3.1.4Łukasz Paczos2018-07-091-1/+1
|
* [iOS] Update annotation view touch handling (with offsets) (#12234)Julian Rex2018-07-096-20/+143
|
* [android] - remove unique LatLng validation of LatLngBounds buildertobrun2018-07-092-35/+35
|
* [android] - fix jni method lookup of GeometryCollection accessor geometries, ↵tobrun2018-07-092-1/+50
| | | | add regression test
* [macos] Updated changelogMinh Nguyễn2018-07-061-6/+11
|
* [ios, macos] Remove duplicate MGLTileSourceOptionDEMEncoding declarationJason Wray2018-07-061-13/+0
|
* [build] add Node as executable for profiling actionKonstantin Käfer2018-07-061-3/+10
| | | | This is now the same as the Run action
* [android] - added DraggableMarkerActivityŁukasz Paczos2018-07-065-13/+360
|
* [android] - added Kotlin dependencies to the test appŁukasz Paczos2018-07-063-5/+15
|
* [ios] Update podspecs for ios-v4.2.0-alpha.2ios-v4.2.0-alpha.2Jason Wray2018-07-053-3/+3
|
* [ios] Update changelog for ios-v4.2.0-alpha.2Jason Wray2018-07-051-7/+5
|
* [docs] Add changelog entries for #12294Chris Loer2018-07-054-4/+11
|
* [core] Only update collision debug data if debug mode is onChris Loer2018-07-051-15/+27
| | | | Fixes issue #12294: unused debug vertices would pile up in buckets over course of tile's lifetime.
* [android] - update changelog for release v6.3.0-alpha.2android-v6.3.0-alpha.2Tobrun2018-07-051-0/+5
|
* [ios] [macos] Added `-[MGLSnapshot coordinateForPoint:]` and associated test.Julian Rex2018-07-055-8/+149
|
* [core] - add LatLng for screencoordinate to mapsnapshottertobrun2018-07-057-12/+37
|
* [android] - add LatLng for pixel conversion feature to MapSnapshottertobrun2018-07-054-2/+25
|
* [android] Consolidate release buildsJohn Firebaugh2018-07-051-105/+9
|
* Rename `HeatmapColorPropertyValue` to `ColorRampPropertyValue`Mikhail Pozdnyakov2018-07-0517-54/+59
| | | | | | | | Based on patch from @lbud (Lauren Budorick). Give `HeatmapColorPropertyValue` a more generic name, since the same value type will be used for both `heatmap-color` and `line-gradient` properties.
* [android] - create device independent tests for camera position testingtobrun2018-07-0517-107/+209
|
* [android] - add bearing and pitch to get camera for geometrytobrun2018-07-056-111/+343
|
* [android] - add bearing and tilt to LatLngBounds, incorporate current tilt ↵tobrun2018-07-055-20/+177
| | | | and bearing transformation in old api
* [android] - avoid race condition when calling getMapAsync from ↵tobrun2018-07-051-7/+12
| | | | OnMapReadyIdlingResource