summaryrefslogtreecommitdiff
path: root/tools/shell/android/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'tools/shell/android/app/build.gradle')
-rw-r--r--tools/shell/android/app/build.gradle40
1 files changed, 40 insertions, 0 deletions
diff --git a/tools/shell/android/app/build.gradle b/tools/shell/android/app/build.gradle
new file mode 100644
index 0000000000..dc43163464
--- /dev/null
+++ b/tools/shell/android/app/build.gradle
@@ -0,0 +1,40 @@
+apply plugin: 'com.android.application'
+
+android {
+ compileSdkVersion 28
+
+ defaultConfig {
+ applicationId = 'com.mapbox.mapboxsdk.maps.shell'
+ minSdkVersion 14
+ targetSdkVersion 28
+
+ ndk {
+ abiFilters 'arm64-v8a'
+ }
+
+ externalNativeBuild {
+ cmake {
+ arguments '-DANDROID_CCACHE=ccache'
+ arguments '-DANDROID_STL=c++_static'
+ targets 'mbgl-shell'
+ }
+ }
+
+ android {
+ testBuildType 'release'
+ }
+ }
+
+ externalNativeBuild {
+ cmake {
+ version '3.10.2'
+ path '../../../../CMakeLists.txt'
+ }
+ }
+
+ buildTypes {
+ release {
+ signingConfig signingConfigs.debug
+ }
+ }
+}