summaryrefslogtreecommitdiff
path: root/next/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'next/test/CMakeLists.txt')
-rw-r--r--next/test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/next/test/CMakeLists.txt b/next/test/CMakeLists.txt
index dc6ea3987c..ce980f78d1 100644
--- a/next/test/CMakeLists.txt
+++ b/next/test/CMakeLists.txt
@@ -110,6 +110,13 @@ add_library(
${MBGL_ROOT}/test/util/url.test.cpp
)
+if(MBGL_WITH_OPENGL)
+ target_compile_definitions(
+ mbgl-test
+ PRIVATE MBGL_RENDER_BACKEND_OPENGL=1
+ )
+endif()
+
if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL Android)
message("Target platform does not support HTTP tests or dependencies not found.")