summaryrefslogtreecommitdiff
path: root/next/platform/node/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'next/platform/node/CMakeLists.txt')
-rw-r--r--next/platform/node/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/next/platform/node/CMakeLists.txt b/next/platform/node/CMakeLists.txt
index 840fab2964..adabd620c3 100644
--- a/next/platform/node/CMakeLists.txt
+++ b/next/platform/node/CMakeLists.txt
@@ -46,7 +46,7 @@ target_link_libraries(
# FIXME: Node bindings only run fully on Linux now because it requires libuv RunLoop (which is the default on Linux). Also, Sanitizer will
# not work here because node will do a dlopen(), which is not currently supported.
-if(CMAKE_SYSTEM_NAME STREQUAL Linux AND NOT CMAKE_BUILD_TYPE STREQUAL Sanitize)
+if(CMAKE_SYSTEM_NAME STREQUAL Linux AND NOT MBGL_WITH_SANITIZER)
add_test(NAME mbgl-node-memory COMMAND npm run test-memory WORKING_DIRECTORY ${MBGL_ROOT})
add_test(NAME mbgl-node-query COMMAND npm run test-query WORKING_DIRECTORY ${MBGL_ROOT})
add_test(NAME mbgl-node-test COMMAND npm run test WORKING_DIRECTORY ${MBGL_ROOT})