summaryrefslogtreecommitdiff
path: root/next/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'next/CMakeLists.txt')
-rw-r--r--next/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/next/CMakeLists.txt b/next/CMakeLists.txt
index 924761ad85..aa26e3a572 100644
--- a/next/CMakeLists.txt
+++ b/next/CMakeLists.txt
@@ -890,7 +890,6 @@ endif(NOT TARGET mapbox-base)
include(${PROJECT_SOURCE_DIR}/vendor/boost.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/earcut.hpp.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/eternal.cmake)
-include(${PROJECT_SOURCE_DIR}/vendor/expected.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/geojson-vt-cpp.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/polylabel.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/protozero.cmake)
@@ -915,6 +914,7 @@ target_link_libraries(
mbgl-vendor-vector-tile
mbgl-vendor-wagyu
PUBLIC
+ Mapbox::Base::Extras::expected-lite
Mapbox::Base::Extras::rapidjson
Mapbox::Base::geojson.hpp
Mapbox::Base::geometry.hpp
@@ -923,7 +923,6 @@ target_link_libraries(
Mapbox::Base::value
Mapbox::Base::variant
Mapbox::Base::weak
- mbgl-vendor-expected
)
set_property(TARGET mbgl-core PROPERTY FOLDER Core)