summaryrefslogtreecommitdiff
path: root/next/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'next/CMakeLists.txt')
-rw-r--r--next/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/next/CMakeLists.txt b/next/CMakeLists.txt
index 6ed7b7a12e..e47be97fe1 100644
--- a/next/CMakeLists.txt
+++ b/next/CMakeLists.txt
@@ -45,6 +45,7 @@ add_compile_options(
$<$<AND:$<COMPILE_LANGUAGE:CXX>,$<NOT:$<PLATFORM_ID:Windows>>>:-Werror>
$<$<AND:$<COMPILE_LANGUAGE:CXX>,$<PLATFORM_ID:Android>>:-Wno-error=tautological-constant-compare>
$<$<CXX_COMPILER_ID:GNU>:-Wno-error=maybe-uninitialized>
+ $<$<CXX_COMPILER_ID:GNU>:-Wno-error=return-type>
$<$<CXX_COMPILER_ID:GNU>:-Wno-error=unknown-pragmas>
$<$<CXX_COMPILER_ID:AppleClang>:-Wno-error=deprecated-declarations>
$<$<CXX_COMPILER_ID:AppleClang>:-Wno-error=unused-parameter>