summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b6b86d9a8d..a02b4b9173 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -176,8 +176,10 @@ if(WITH_NODEJS AND COMMAND mbgl_platform_node)
endif()
if(CMAKE_GENERATOR STREQUAL "Xcode")
- write_xcconfig_target_properties(
- mbgl-core
- mbgl-filesource
+ set_xcconfig_target_properties(mbgl-core)
+ set_xcconfig_target_properties(mbgl-filesource)
+ file(GENERATE
+ OUTPUT "${CMAKE_BINARY_DIR}/config.xcconfig"
+ INPUT "${CMAKE_SOURCE_DIR}/scripts/config.xcconfig.in"
)
endif()