summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49f3443d9e..b612e508ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,10 @@
cmake_minimum_required(VERSION 3.1)
-project(mbgl LANGUAGES CXX C)
+
+if(NOT MBGL_PROJECT_NAME)
+ set(MBGL_PROJECT_NAME mbgl)
+endif()
+
+project(${MBGL_PROJECT_NAME} LANGUAGES CXX C)
set(CMAKE_CXX_STANDARD 14)
include(cmake/mbgl.cmake)